Updated to version 1.5.7 (No downtime)
Incident Report for PDF Blocks
Resolved
The servers were updated to the latest version of PDF Blocks.
Posted Jun 08, 2021 - 04:30 UTC